Как исправить ошибку при загрузке ocmod модулей в Opencart2

Те кто только начал осваивать Opencart2, неизбежно сталкивается с ошибкой загрузки ocmod-модулей при установке через установщик модулей, то есть система хочет, чтобы мы в настройках магазина прописали FTP доступы.

И это не всегда возможно – сайт находится на локальном вебсервере или по каким либо иным причинам (для меня таковой является,
что просто нет желания светить свои FTP данные в админке, хотя конечно если получен доступ к админке далее взломать хостинг не составит труда).

Далее анализируя данную ошибку можно понять,
что файлы типа ocmod.xml могут загружаться и без FTP. Получается, что можно загружать и без FTP, но данное действие требует установки модуля). И модулем для решения данной проблемы является разработка
компании iSense QuickFix: Extensions Installer issue when FTP support disabled (https://www.opencart.com/index.php?route=marketplace/extension/info&extension_id=18892&filter_license=0&filter_download_id=40&page=4)


Необходимо скачать модуль по ссылке, разархивировать и загрузить ocmod.xml на сайт с нашим Opencart, далее объязательно обновить модификаторы и мы сможем устанавливать расширения формата ocmod.zip
Основным и важным условием для работы такого решения является отключенный FTP в настройках магазина (в нем никаких данных быть не должно).

И, как обычно, для тех кому лениво читать – видео вариант поста на моем канале Youtube

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Пролистать наверх